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QuPath

• What is QuPath
QuPath is an open source , powerful, flexible, extensible software platform for 

whole slide image analysis. Some typical applications include: cell counting, positive 
cell determination, cell classification, multiplex fluorescence analysis, etc.

• Minimum requirements to run QuPath
* Qupath can work on 64 bit Windows, MAC and Linux environment
* Recommended hardware setup: intel core i7 or above, 16GB RAM
* If you are dealing with large data set (for example: Z-stack, multiplexed image),         

>16GB RAM is strongly recommended .



Qupath versions and download
• Current stable version 

Qupath Version 0.2.3

• Download link: https://github.com/qupath/qupath/releases/tag/v0.2.3

• FAQ site: https://forum.image.sc/tags/qupath

• What to download
* For windows (two options, Option 1 recommended): 

Option 1 (without administrator permission) : QuPath-0.2.3-windows.zip
Unzip it and run QuPath-v0.2.3.exe 

Option 2 (with administrator permission):             QuPath-0.2.3-Windows.msi
Standard windows installer

* For MAC: QuPath-0.2.3-Mac.pkg
* For Linux:   QuPath-0.2.3-Linux.tar.xz



Image Format supported by QuPath

• QuPath supports a wide range of image formats, including many whole slide 
formats.

• To support different image formats, two essential open source libraries are used in 
Qupath. For details please check following links respectively:
* Bio-formats: https://docs.openmicroscopy.org/bio-formats
* OpenSlide: https://openslide.org

• As a quick summary, following WSI image formats are supported:
Aperio SVS/SCN, Ventana BIF, Zeiss CZI, Hamamatsu NDPI, 3D-Histech MRXS 

(may need to covert to OME-TIFF), JPG/JP2/Some TIFF formats



QuPath‐Setup

When running QuPath for the first 
time, you will see a setup window, 
shown on left.  QuPath will request 
50% of the total memory available in 
your system, this is the default 
setting. Generally speaking, the 
software will perform better if your 
system has more memories. 



QuPath‐ Software Layout
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Software Layout:

1 Command menu

2 Functional keys

3 Operational tabs

4 Information summary window

5 Image viewer



QuPath-Project Tab

We can view and analyze single image using QuPath. However in 
digital pathology, we always need to manage and process multiple 
images in batch mode. It is highly recommended to use Project
function.  Especially , if you want to analyze our Versa SCN 
fluorescence image, you  have to use Project function to open/load 
the image properly.

Create Project: File-> Project…-> Create Project

Project provides a way to:
• Group together related images
• Easily switch between images (by clicking on thumbnails in the 

project image list)
• Organize your data files, along with scripts, classifiers and other 

useful things
• View a larger thumbnail and some file data by hovering the 

mouse over an image, without needing to open it fully

Caution:
When you want to transfer /share your project with other user, 
please make sure both of you are using the same QuPath version.
Project created by version 0.2.x cannot be opened by version 0.1.x.
Also, when you transfer the project to another computer, you also 
need to maintain the folder structure.

Project view & folder structure  

For example: if you have image files at C:\Qupath-Demo\IHC-
data, you can create a blank subfolder first: IHC-projectDemo

When you use QuPath to create the project, assign the above 
IHC-projectDemo folder to be the project folder, QuPath will 
then generate a project file and some subfolders for future 
computational purposes, as shown below:



QuPath-Project Tab
Add images to project

Add images to project:
1: click Add images from top left;
2: Import images to project: you will see
this dialogue window;
3: Set image type: H&E / H-DAB /H-
other/FL, etc.;
4: click Choose files to select images you
want to add to the project;
5: then click Import

After importing images, you will see a
image list on the left, if you select one
image and click, that image will be shown
in the viewer on right:
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QuPath‐Image Tab

When an image is selected, you 
can check and view the image 
properties from the Image Tab. 
Some fundamental image 
information will be listed here, 
for example: magnification, 
image size, pixel size, etc.



QuPath‐Annotation 

In digital pathology image
processing, the first step is typically
annotation- defining your region of
interest. You can access annotation
tools either from command menu –
Tools or from functional keys from
top left. You can define your ROI by
regular shapes or polygon or brush,
etc.

: This is the Move key, when click,
you can pan the image within the
image viewer window.



Qupath‐Annotation Tab

Annotation example (shown on left):
1: all annotation regions are organized/ listed in 
Annotation Tab;

2: Information summary window: annotation 
summary information will be listed here;

3: Image viewer: couple of ROIs are highlighted in 
image viewer.

Some online annotation tutorials:

https://www.youtube.com/watch?v=FAoUHu40dk0

https://www.youtube.com/watch?v=lGj3uyxUdgs
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QuPath‐Annotation
Shortcut keys

• Shortcut keys for the tools and commands you 
use most frequently can help a lot to get things 
done quickly, and with less frustration.

• ALT Key
* When the Move tool is selected, use the Alt key 

to click on multiple objects to select them.
* When the Brush or Wand tools are selected, use 

the Alt key to switch to 'eraser' mode when drawing

• Shift Key
* When the Brush orWand tools are selected, 

use the Shift key to continue adding to an existing 
selected annotation (rather than creating a new 
one).

• Note for Linux users 
Replace Alt with Alt + Super

Drawing and navigation



QuPath – Other Shortcut keys

Display Shortcuts Command Shortcuts



QuPath – Cell Object Detection
Now images are organized in project and ROIs are defined by annotations.
We can start to investigate the data set and understand different processing
functions in QuPath.

The fundamental concept in QuPath is object detection-more specifically,
nucleus object detection. Watershed segmentation technique is applied for
this purpose.

WaterShed Cell Detection :
Analyze->Cell detection->Cell detection

Parameters used for cell detection :
* Setup parameters
* Nucleus parameters
* Intensity parameters
* Cell parameters

Recommendations:

• When using QuPath processing functions, you can always start with 
default parameter settings, then compare result image with original 
image to see if any parameter needs to be modified;

• Parameter definition can be viewed by moving mouse cursor on top 
of the parameter name, for example highlighted by       :

Background radius: radius for background estimation
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QuPath – Cell Object Detection

WaterShed cell detection details:

* Setup parameters
Detection image: Hematoxylin optical density or Overall optical density 
Requested pixel size: pixel size for computation

* Nucleus parameters
Background radius : if background subtraction is considered, 0 means no        

background subtraction
Median filter radius: reduce image texture / smooth intensity vibrations
Sigma: control /reduce the noise effect, smaller number you will get more  

nucleus (more fragments)
Minimum/Maximum area: define the range of nucleus size 

* Intensity parameters
Threshold : the lower intensity threshold for nucleus object
Max background intensity: the upper intensity threshold for nucleus object

* Cell parameters
Cell expansion : based on detected nucleus objects, define cell size



QuPath – Cell detection example

Yellow ROI containing some cell objects 116 cells are identified, highlighted in red



QuPath- Cell positivity
In IHC (H-DAB) image analysis, after cell
objects are detected based on Hematoxylin
channel, we can further determine positive
cells stained by DAB (brown channel) .

Positive cell detection:
Analyze->Cell detection-> Positive cell
detection

Parameters in the yellow region (Shown in
left image) can be adjusted to determine
positive cells (cells with brown staining).

H-score can be computed after this
positivity determination.



QuPath – Cell positivity example

116 cells are detected from previous step

Applying  single thresholding:  Nucleus 
DAB mean  intensity >0.2, one positive 
cell is identified and highlighted in green 

1

Summary information is listed in 
region 1



QuPath- Cell Classification-Object Features

1

At WaterShed cell detection step, cell object
features are computed. If you click one
identified cell object (yellow one)in the
viewer, feature measurements are shown in
region 1

You can also find the cell object feature list by 
clicking:
Measure -> Show measurement manager
The total feature number is 41 at this point.



QuPath- Cell Classification-Feature selection

In digital pathology image processing,
another popular application task is
classification-to separate different cell
types based on cell object features.
For example, if we want to separate
TDLU cells (red region ) and Not
TDLU cells (black region ), we need to
investigate their object feature
measurements and select the proper
feature /feature combination for optimal
separation.

1

2

1
2



QuPath- Cell Classification-Feature investigation

You can investigate object features by clicking:
Measure – Measurement maps

Dialogue window for Measurement maps
41 cell object features are listed here
Current selected feature: Nucleus/Cell area ratio

Color template to highlight the difference
Current selected: inferno

Feature threshold
By moving the control bar, you can change the
threshold; current threshold is 0.21;

Highlighted result in Image viewer
Dark objects are rejected : Not TDLU cells
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QuPath- Cell Classification- Single measurement classifier
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From feature investigation step, we find a possible object
feature- Nucleus/Cell area ratio for separation, now we
can create a simple classifier by clicking:
Classify -> Object classification -> Create single
measurement classifier

At this window, you can add new class definition by
right clicking your mouse button, in this example, two
classes are added –TDLU (red) and Not TDLU (yellow);

In this classifier window, you can choose
Nucleus/Cell area ratio as selected feature for
separation, then define your separation threshold as 0.21;

In image viewer window, the result will be shown:
red object representing TDLU cells, yellow color
representing Not TDLU cells;

TDLU cell counts and Not TDLU cell counts will be
summarized in this summary window.
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In practical, separation result based on single feature is not good 
enough. Then we need to apply classification models to include 
more features into consideration.

Find Create detection classifier window by clicking:
Classify -> object classification ->older classifier-> Create 
detection classifier

From this window, you can find some popular classification 
models: Boosted Decision Trees/Decision Trees/K Nearest 
Neighbors/Neural Network/Normal Bayes Classifier/ Random 
Trees/SVM 

Model performance is basically data-dependent. Due to robustness 
and less training input, Random Tree is a suggested option for 
initial data investigation.

Here is a link to describe the concept of  random trees:

https://towardsdatascience.com/understanding-random-forest-
58381e0602d2 

Classification procedure contains three steps:
* Training: annotate and select cell objects for different cell types
* Validating: prepare a region with mixed cell types
* Building classifier: select classifier model and features, build
the classifier using training set and apply the classifier on
validating region

QuPath- Cell Classification- Cell classification-Classification models



Training data input:

• In image viewer, use annotation tools to define TDLU 
cells (                   )  and Not TDLU cells (             ) , 
and assign them to proper class respectively by 
clicking  Set class        ;

• Then use Watershed cell object detection to obtain the 
feature measurements, totally 41 cell object features 
will be computed.

QuPath- Cell Classification- Cell classification- Build Random Trees Classifier
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Prepare validation set :

• In image viewer, use annotation tools to define another 
region with mixed TDLU & Not TDLU cells   

• Then use Watershed cell object detection to detect cell 
objects in this region.

QuPath- Cell Classification- Cell classification- Build Random Trees Classifier
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Build classifier and apply it to validation 
region:

Now, open the Create detection classifier 
window, load the training data by clicking 
Use all       , for this example , totally 84 
objects and 41 features        are used to 
compute the classifier. Then, click Build & 
Apply         , result will be shown in 
validating region      . Sometimes, based on 
result, you can add/remove object features 
for purpose by clicking Select      .
Now in validation region, TDLU cells are 
highlighted in red, Not TDLU cells are in 
yellow.

QuPath- Cell Classification- Cell classification- Build Random Trees Classifier
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QuPath- Cell Classification-Update

From current  version, QuPath starts to change 
the dialogue window layout/appearance. For 
example, Train object classifier  will replace 
the Create detection classifier in future, 
Train object classifier can be found by 
clicking:
Classify->Object classification-> Train 
object classifier  or Shortcut : Ctrl+Shift+D

Train object classifier        still uses the same 
classification concepts, it gives you an extra 
classification pie chart. You can define a name 
to the classifier and save the classifier for 
future use.   
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QuPath‐Result
Result :

Annotation summary list

Detection result summary

Detection highlighted in viewer   

On/Off detection markup   
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